AppDirect Service Outage
Incident Report for Pivotal Web Services
Postmortem

From 2019-10-28 08:40 PT, third party service creation and management through AppDirect was failing. This was due to a misconfiguration in AppDirect, resulting in authentication failures with the AppDirect broker until 2019-10-28 14:01 PT when a modification was made to the problematic authorization service’s configuration.

Posted Oct 31, 2019 - 14:05 PDT

Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 16:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2019 - 14:21 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 28, 2019 - 14:12 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 28, 2019 - 14:05 PDT
Update
This issue was incorrectly marked as an outage to existing service instances, when in fact it is an outage to service provisioning requests to the AppDirect broker, which constitutes part of the Marketplace Services API.
Posted Oct 28, 2019 - 13:58 PDT
Investigating
We are currently investigating failures to perform service lifecycle operations for services provided by the AppDirect service broker.
Posted Oct 28, 2019 - 12:19 PDT
This incident affected: Marketplace Services API.